CentOS setup 명령어를 찾지 못했을때 조치사항

 

 

 

Centos setup 명령어를 찾지 못했을때 조치사항 

 

SUB Title : centos setup command not found 

빠른 설치를 위한 요약본

#setup 명령어 실행시 해당 명령어를 찾지 못한다면 해당 페키지를 설치하지 않았을 가능성이 매우 높다.(아래 참고)

 

 

처음 Centos 설치과정에서 next next 만 반복적으로 누르다 보면 CentOS의 기본값인 minimal 버전으로 설치가 되는대

 

이경우가 setup 페키지가 설치되지 않는 경우이다.

 

 

 

간단히 네트웍에 연결된(IP설정을 한) 상태라면 아래의 명령어 4줄만 입력하면 SETUP 명령어를 사용할 수 있다.

 

 

[root@localhost ~]# yum install setup

 

[root@localhost ~]# yum install setuptool

 

[root@localhost ~]# yum install system-config-*

 

[root@localhost ~]# yum install ntsysv-1.3.49.3-2.el6.x86_64

 

그렇지 않을경우에는 아래 네트워크 수동 설정부터 차근차근 따라해 보자

네트워크 설정 

setup 명령어가 주로 네트워크 설정이나 서비스 설정, 그리고 방화벽 설정 할때 많이 사용되는데..

어쩌겠는가 해당 패키지가 없으니 우선 네트웍만 수동으로 설정해 보겠다.

 

이더넷 포트는 eth0 부터 eth1, eth2, eth3... 쭉 순차적으로 진행되는데

 

아래는 eth0 기준으로 설정을 진행한다.

 

 

가) DHCP를 사용하는 경우 아래와 같이 내용을 편집한다.

 

#/etc/rc.d/init.d/network restart 

 

BOOTPROTO=dhcp

ONBOOT=yes

 

#/etc/rc.d/init.d/network restart

 


나) 고정(statIc) 으로 설정할 경우 IP설정과 DNS 설정을 진행한다.

 

#/etc/rc.d/init.d/network restart

 

BOOTPROTO=none

ONBOOT=yes

NETMASK=255.255.255.0

IPADDR= xxx.xxx.xxx.xxx

GATEWAY=xxx.xxx.xxx.xxx

 

#/etc/rc.d/init.d/network restart

#vi /etc/resolv.conf

 

nameserver 8.8.8.8

#

 

해당 설정후 네트웍 연결이 정상적으로 된다면 처음의 명령어 3줄을 입력하여 설치를 진행하자.

 

아래는 보다 상세한 설치 내용을 설명하고 있다.

페키지 설치 1단게

아래의 명령어를 기입한다.

 

[root@localhost ~]# yum install setup

 


Loaded plugins: fastestmirror
base                                                     | 3.7 kB     00:00
base/primary_db                                          | 4.4 MB     00:00
extras                                                   | 3.4 kB     00:00
extras/primary_db                                        |  18 kB     00:00
updates                                                  | 3.4 kB     00:00
updates/primary_db                                       | 3.1 MB     00:00
Setting up Install Process
Package setup-2.8.14-20.el6.noarch already installed and latest version
[root@localhost ~]#

페키지 설치 2단계 

아래의 명령어를 기입한다.

 

[root@localhost ~]# yum install setuptool

 


Loaded plugins: fastestmirror
Determining fastest mirrors
 * base: data.nicehosting.co.kr
 * extras: data.nicehosting.co.kr
 * updates: data.nicehosting.co.kr
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package setuptool.x86_64 0:1.19.9-3.el6 will be installed
--> Processing Dependency: usermode for package: setuptool-1.19.9-3.el6.x86_64
--> Running transaction check
---> Package usermode.x86_64 0:1.102-3.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch            Version                 Repository     Size
================================================================================
Installing:
 setuptool          x86_64          1.19.9-3.el6            base           59 k
Installing for dependencies:
 usermode           x86_64          1.102-3.el6             base          187 k

Transaction Summary
================================================================================
Install       2 Package(s)

Total download size: 246 k
Installed size: 918 k
Is this ok [y/N]: y
Downloading Packages:
(1/2): setuptool-1.19.9-3.el6.x86_64.rpm                   |  59 kB     00:00
(2/2): usermode-1.102-3.el6.x86_64.rpm                     | 187 kB     00:00
----------------------------------------------------------------------------------
Total                                             513 kB/s | 246 kB     00:00
warning: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID c105b9de: NOKEY
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
Importing GPG key 0xC105B9DE:
 Userid : CentOS-6 Key (CentOS 6 Official Signing Key) <centos-6-key@centos.org>
 Package: centos-release-6-4.el6.centos.10.x86_64 (@anaconda-CentOS-201303020151.x86_64/6.4)
 From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
Is this ok [y/N]: y
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : usermode-1.102-3.el6.x86_64                                    1/2
  Installing : setuptool-1.19.9-3.el6.x86_64                                  2/2
  Verifying  : setuptool-1.19.9-3.el6.x86_64                                  1/2
  Verifying  : usermode-1.102-3.el6.x86_64                                    2/2

Installed:
  setuptool.x86_64 0:1.19.9-3.el6

Dependency Installed:
  usermode.x86_64 0:1.102-3.el6

Complete!
[root@localhost ~]#

 

여기까지 설치하고 #setup 명령어를 입력하면 실행은 되지만 아래와 같이 메뉴가 하나 밖에 나오지 않는다.

 

페키지 설치 3단계 

아래와같이 명령어를 입력하면 약 261개(절대적이지 않음) 설치가 필요하단 메시지가 출력된다.

 

엔터치고 차한잔 마시고 오면 설치가 완료되어 있을 것이다.

 

[root@localhost ~]# yum install system-config-*

  

 

Installed:
  system-config-date.noarch 0:1.9.60-1.el6.centos
  system-config-date-docs.noarch 0:1.0.11-1.el6
  system-config-firewall.noarch 0:1.2.27-5.el6
  system-config-firewall-base.noarch 0:1.2.27-5.el6
  system-config-firewall-tui.noarch 0:1.2.27-5.el6
  system-config-kdump.noarch 0:2.0.5-15.el6
  system-config-keyboard.x86_64 0:1.3.1-4.el6
  system-config-keyboard-base.x86_64 0:1.3.1-4.el6
  system-config-kickstart.noarch 0:2.8.6.5-1.el6
  system-config-language.noarch 0:1.3.4-6.el6
  system-config-lvm.noarch 0:1.1.12-15.el6
  system-config-network-tui.noarch 0:1.6.0.el6.2-1.el6
  system-config-printer.x86_64 0:1.1.16-23.el6
  system-config-printer-libs.x86_64 0:1.1.16-23.el6
  system-config-printer-udev.x86_64 0:1.1.16-23.el6
  system-config-services.noarch 0:0.99.45-1.el6.3
  system-config-services-docs.noarch 0:1.1.8-1.el6
  system-config-users.noarch 0:1.2.106-7.el6
  system-config-users-docs.noarch 0:1.0.8-1.el6

Dependency Installed:
  ConsoleKit.x86_64 0:0.4.1-3.el6
  ConsoleKit-libs.x86_64 0:0.4.1-3.el6
  GConf2.x86_64 0:2.28.0-6.el6
  ModemManager.x86_64 0:0.4.0-3.git20100628.el6
  NetworkManager.x86_64 1:0.8.1-43.el6
  NetworkManager-glib.x86_64 1:0.8.1-43.el6
  ORBit2.x86_64 0:2.14.17-3.2.el6_3
  alsa-lib.x86_64 0:1.0.22-3.el6
  anaconda.x86_64 0:13.21.195-1.el6.centos.1
  anaconda-yum-plugins.noarch 1:1.0-5.1.el6
  atk.x86_64 0:1.28.0-2.el6
  authconfig-gtk.x86_64 0:6.1.12-13.el6
  avahi-autoipd.x86_64 0:0.6.25-12.el6
  avahi-glib.x86_64 0:0.6.25-12.el6
  avahi-libs.x86_64 0:0.6.25-12.el6
  bc.x86_64 0:1.06.95-1.el6
  btparser.x86_64 0:0.17-1.el6
  busybox.x86_64 1:1.15.1-15.el6
  cairo.x86_64 0:1.8.8-3.1.el6
  comps-extras.noarch 0:17.8-1.el6
  control-center-filesystem.x86_64 1:2.28.1-38.el6
  cracklib-python.x86_64 0:2.8.16-4.el6
  crda.x86_64 0:1.1.1_2010.11.22-1.el6
  createrepo.noarch 0:0.9.9-17.el6
  cryptsetup-luks.x86_64 0:1.2.0-7.el6
  cryptsetup-luks-libs.x86_64 0:1.2.0-7.el6
  cups-libs.x86_64 1:1.4.2-50.el6_4.4
  dbus.x86_64 1:1.2.24-7.el6_3
  dbus-python.x86_64 0:0.83.0-6.1.el6
  dbus-x11.x86_64 1:1.2.24-7.el6_3
  deltarpm.x86_64 0:3.5-0.5.20090913git.el6
  desktop-file-utils.x86_64 0:0.15-9.el6
  device-mapper-multipath.x86_64 0:0.4.9-64.el6
  device-mapper-multipath-libs.x86_64 0:0.4.9-64.el6
  dmidecode.x86_64 1:2.11-2.el6
  dmraid.x86_64 0:1.0.0.rc16-11.el6
  dmraid-events.x86_64 0:1.0.0.rc16-11.el6
  dmz-cursor-themes.noarch 0:0.4-4.el6
  dnsmasq.x86_64 0:2.48-13.el6
  docbook-dtds.noarch 0:1.0-51.el6
  dosfstools.x86_64 0:3.0.9-4.el6
  eggdbus.x86_64 0:0.6-3.el6
  elfutils-libs.x86_64 0:0.152-1.el6
  fcoe-utils.x86_64 0:1.0.24-2.el6
  firstboot.x86_64 0:1.110.14-1.el6
  flac.x86_64 0:1.2.1-6.1.el6
  fontconfig.x86_64 0:2.8.0-3.el6
  fontpackages-filesystem.noarch 0:1.41-1.1.el6
  freetype.x86_64 0:2.3.11-14.el6_3.1
  gamin-python.x86_64 0:0.1.10-9.el6
  genisoimage.x86_64 0:1.1.9-12.el6
  gnome-doc-utils-stylesheets.noarch 0:0.18.1-1.el6
  gnome-icon-theme.noarch 0:2.28.0-2.el6
  gnome-keyring.x86_64 0:2.28.2-8.el6_3
  gnome-python2.x86_64 0:2.28.0-3.el6
  gnome-python2-bonobo.x86_64 0:2.28.0-3.el6
  gnome-python2-canvas.x86_64 0:2.28.0-3.el6
  gnome-python2-desktop.x86_64 0:2.28.0-4.el6
  gnome-python2-gnome.x86_64 0:2.28.0-3.el6
  gnome-python2-gnomekeyring.x86_64 0:2.28.0-4.el6
  gnome-python2-gnomevfs.x86_64 0:2.28.0-3.el6
  gnome-themes.noarch 0:2.28.1-6.el6
  gnome-user-docs.noarch 0:2.28.0-4.el6
  gnome-vfs2.x86_64 0:2.24.2-6.el6
  gnutls.x86_64 0:2.8.5-10.el6_4.2
  gstreamer.x86_64 0:0.10.29-1.el6
  gstreamer-tools.x86_64 0:0.10.29-1.el6
  gtk2.x86_64 0:2.18.9-12.el6
  gtk2-engines.x86_64 0:2.18.4-5.el6.centos
  hal-libs.x86_64 0:0.5.14-11.el6
  hicolor-icon-theme.noarch 0:0.11-1.1.el6
  hunspell.x86_64 0:1.2.8-16.el6
  iscsi-initiator-utils.x86_64 0:6.2.0.873-2.el6
  isomd5sum.x86_64 1:1.0.6-1.el6
  iw.x86_64 0:0.9.17-4.el6
  jasper-libs.x86_64 0:1.900.1-15.el6_1.1
  kexec-tools.x86_64 0:2.0.0-258.el6_4.2
  kpartx.x86_64 0:0.4.9-64.el6
  libICE.x86_64 0:1.0.6-1.el6
  libIDL.x86_64 0:0.8.13-2.1.el6
  libSM.x86_64 0:1.2.1-2.el6
  libX11.x86_64 0:1.5.0-4.el6
  libX11-common.noarch 0:1.5.0-4.el6
  libXau.x86_64 0:1.0.6-4.el6
  libXcomposite.x86_64 0:0.4.3-4.el6
  libXcursor.x86_64 0:1.1.13-2.el6
  libXdamage.x86_64 0:1.1.3-4.el6
  libXdmcp.x86_64 0:1.1.1-3.el6
  libXext.x86_64 0:1.3.1-2.el6
  libXfixes.x86_64 0:5.0-3.el6
  libXfont.x86_64 0:1.4.5-2.el6
  libXft.x86_64 0:2.3.1-2.el6
  libXi.x86_64 0:1.6.1-3.el6
  libXinerama.x86_64 0:1.1.2-2.el6
  libXmu.x86_64 0:1.1.1-2.el6
  libXrandr.x86_64 0:1.4.0-1.el6
  libXrender.x86_64 0:0.9.7-2.el6
  libXres.x86_64 0:1.0.6-2.el6
  libXt.x86_64 0:1.1.3-1.el6
  libXtst.x86_64 0:1.2.1-2.el6
  libXxf86vm.x86_64 0:1.1.2-2.el6
  libaio.x86_64 0:0.3.107-10.el6
  libarchive.x86_64 0:2.8.3-4.el6_2
  libart_lgpl.x86_64 0:2.3.20-5.1.el6
  libasyncns.x86_64 0:0.8-1.1.el6
  libbonobo.x86_64 0:2.24.2-5.el6
  libbonoboui.x86_64 0:2.24.2-3.el6
  libcanberra.x86_64 0:0.22-1.el6.centos
  libcanberra-gtk2.x86_64 0:0.22-1.el6.centos
  libconfig.x86_64 0:1.3.2-1.1.el6
  libdaemon.x86_64 0:0.14-1.el6
  libedit.x86_64 0:2.11-4.20080712cvs.1.el6
  liberation-fonts-common.noarch 0:1.05.1.20090721-5.el6
  liberation-sans-fonts.noarch 0:1.05.1.20090721-5.el6
  libfontenc.x86_64 0:1.0.5-2.el6
  libglade2.x86_64 0:2.6.4-3.1.el6
  libgnome.x86_64 0:2.28.0-11.el6
  libgnomecanvas.x86_64 0:2.26.0-4.el6
  libgnomeui.x86_64 0:2.24.1-4.el6
  libgudev1.x86_64 0:147-2.46.el6
  libhbaapi.x86_64 0:2.2.6-1.el6
  libhbalinux.x86_64 0:1.0.14-1.el6
  libjpeg-turbo.x86_64 0:1.2.1-1.el6
  libnl.x86_64 0:1.1-14.el6
  libnotify.x86_64 0:0.5.0-1.el6
  libogg.x86_64 2:1.1.4-2.1.el6
  libpcap.x86_64 14:1.0.0-6.20091201git117cb5.el6
  libpng.x86_64 2:1.2.49-1.el6_2
  libproxy.x86_64 0:0.3.0-4.el6_3
  libproxy-bin.x86_64 0:0.3.0-4.el6_3
  libproxy-python.x86_64 0:0.3.0-4.el6_3
  libreport.x86_64 0:2.0.9-15.el6.centos
  libreport-compat.x86_64 0:2.0.9-15.el6.centos
  libreport-gtk.x86_64 0:2.0.9-15.el6.centos
  libreport-newt.x86_64 0:2.0.9-15.el6.centos
  libreport-plugin-reportuploader.x86_64 0:2.0.9-15.el6.centos
  libreport-plugin-rhtsupport.x86_64 0:2.0.9-15.el6.centos
  libreport-python.x86_64 0:2.0.9-15.el6.centos
  libselinux-python.x86_64 0:2.0.94-5.3.el6_4.1
  libsmbclient.x86_64 0:3.6.9-151.el6
  libsndfile.x86_64 0:1.0.20-5.el6
  libtalloc.x86_64 0:2.0.7-2.el6
  libtar.x86_64 0:1.2.11-17.el6
  libtasn1.x86_64 0:2.3-3.el6_2.1
  libtdb.x86_64 0:1.2.10-1.el6
  libthai.x86_64 0:0.1.12-3.el6
  libtiff.x86_64 0:3.9.4-9.el6_3
  libtool-ltdl.x86_64 0:2.2.6-15.5.el6
  libuser-python.x86_64 0:0.56.13-5.el6
  libvorbis.x86_64 1:1.2.3-4.el6_2.1
  libwnck.x86_64 0:2.28.0-3.el6
  libxcb.x86_64 0:1.8.1-1.el6
  libxkbfile.x86_64 0:1.0.6-1.1.el6
  libxml2-python.x86_64 0:2.7.6-12.el6_4.1
  libxslt.x86_64 0:1.1.26-2.el6_3.1
  lldpad.x86_64 0:0.9.45-7.el6
  lldpad-libs.x86_64 0:0.9.45-7.el6
  makebootfat.x86_64 0:1.4-10.el6
  mdadm.x86_64 0:3.2.5-4.el6_4.1
  mesa-dri-drivers.x86_64 0:9.0-0.8.el6_4.3
  mesa-dri-filesystem.x86_64 0:9.0-0.8.el6_4.3
  mesa-dri1-drivers.x86_64 0:7.11-8.el6
  mesa-libGL.x86_64 0:9.0-0.8.el6_4.3
  metacity.x86_64 0:2.28.0-23.el6
  mobile-broadband-provider-info.noarch 0:1.20100122-1.el6
  mozilla-filesystem.x86_64 0:1.9-5.1.el6
  mtools.x86_64 0:4.0.12-1.el6
  notification-daemon.x86_64 0:0.5.0-1.el6
  notify-python.x86_64 0:0.1.1-10.el6
  ntp.x86_64 0:4.2.4p8-3.el6.centos
  ntpdate.x86_64 0:4.2.4p8-3.el6.centos
  openssh-clients.x86_64 0:5.3p1-84.1.el6
  pango.x86_64 0:1.28.1-7.el6_3
  parted.x86_64 0:2.1-19.el6
  pciutils.x86_64 0:3.1.10-2.el6
  perl.x86_64 4:5.10.1-131.el6_4
  perl-Module-Pluggable.x86_64 1:3.90-131.el6_4
  perl-Pod-Escapes.x86_64 1:1.04-131.el6_4
  perl-Pod-Simple.x86_64 1:3.13-131.el6_4
  perl-libs.x86_64 4:5.10.1-131.el6_4
  perl-version.x86_64 3:0.77-131.el6_4
  pixman.x86_64 0:0.26.2-5.el6_4
  pkgconfig.x86_64 1:0.23-9.1.el6
  polkit.x86_64 0:0.96-2.el6_0.1
  ppp.x86_64 0:2.4.5-5.el6
  pulseaudio-libs.x86_64 0:0.9.21-14.el6_3
  pycairo.x86_64 0:1.8.6-2.1.el6
  pygobject2.x86_64 0:2.20.0-5.el6
  pygtk2.x86_64 0:2.16.0-3.el6
  pygtk2-libglade.x86_64 0:2.16.0-3.el6
  pykickstart.noarch 0:1.74.12-1.el6
  pyorbit.x86_64 0:2.24.0-5.el6
  pyparted.x86_64 0:3.4-3.el6
  python-cryptsetup.x86_64 0:0.0.11-1.el6
  python-decorator.noarch 0:3.0.1-3.1.el6
  python-deltarpm.x86_64 0:3.5-0.5.20090913git.el6
  python-ethtool.x86_64 0:0.6-3.el6
  python-iwlib.x86_64 0:0.1-1.2.el6
  python-meh.noarch 0:0.12.1-3.el6
  python-nss.x86_64 0:0.13-1.el6
  python-pyblock.x86_64 0:0.48-1.el6
  python-slip.noarch 0:0.2.20-1.el6_2
  python-slip-dbus.noarch 0:0.2.20-1.el6_2
  python-slip-gtk.noarch 0:0.2.20-1.el6_2
  pyxf86config.x86_64 0:0.3.37-7.1.el6
  rarian.x86_64 0:0.8.1-5.1.el6
  rarian-compat.x86_64 0:0.8.1-5.1.el6
  samba-common.x86_64 0:3.6.9-151.el6
  samba-winbind.x86_64 0:3.6.9-151.el6
  samba-winbind-clients.x86_64 0:3.6.9-151.el6
  sgml-common.noarch 0:0.6.3-32.el6
  sgpio.x86_64 0:1.2.0.10-5.el6
  shared-mime-info.x86_64 0:0.70-4.el6
  sound-theme-freedesktop.noarch 0:0.7-3.el6
  squashfs-tools.x86_64 0:4.0-5.el6
  startup-notification.x86_64 0:0.10-2.1.el6
  syslinux.x86_64 0:4.02-8.el6
  system-gnome-theme.noarch 0:60.0.2-1.el6
  system-icon-theme.noarch 0:6.0.0-2.el6
  tigervnc-server.x86_64 0:1.1.0-5.el6_4.1
  urw-fonts.noarch 0:2.4-10.el6
  usermode-gtk.x86_64 0:1.102-3.el6
  wireless-tools.x86_64 1:29-5.1.1.el6
  wpa_supplicant.x86_64 1:0.7.3-4.el6_3
  xcb-util.x86_64 0:0.3.6-1.el6
  xdg-utils.noarch 0:1.0.2-17.20091016cvs.el6
  xkeyboard-config.noarch 0:2.6-6.el6
  xml-common.noarch 0:0.6.3-32.el6
  xmlrpc-c.x86_64 0:1.16.24-1209.1840.el6
  xmlrpc-c-client.x86_64 0:1.16.24-1209.1840.el6
  xorg-x11-font-utils.x86_64 1:7.2-11.el6
  xorg-x11-fonts-misc.noarch 0:7.2-9.1.el6
  xorg-x11-xauth.x86_64 1:1.0.2-7.1.el6
  xorg-x11-xkb-utils.x86_64 0:7.7-4.el6
  xulrunner.x86_64 0:17.0.6-2.el6.centos
  xz.x86_64 0:4.999.9-0.3.beta.20091007git.el6
  yelp.x86_64 0:2.28.1-17.el6_3
  yum-utils.noarch 0:1.1.30-14.el6
  zenity.x86_64 0:2.28.0-1.el6

Dependency Updated:
  libselinux.x86_64 0:2.0.94-5.3.el6_4.1  libselinux-utils.x86_64 0:2.0.94-5.3.el6_4.1
  libxml2.x86_64 0:2.7.6-12.el6_4.1

Complete!

 

완료후 setup 명령어를 치면 아래와 같이 정상적으로 표시된다.

 



 

 

댓글()